华为mstp、vrrp、ospf、isis、bgp等综合一起排错

在这里插入图片描述

最终实现左边私网和右边私网全部ping通

SW1

vlan batch 12 34

stp region-configuration //mstp配置
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/10
port link-type access
port default vlan 12

interface GigabitEthernet0/0/11
port link-type access
port default vlan 12

SW2

vlan batch 12 34
stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/10
port link-type access
port default vlan 34

interface GigabitEthernet0/0/11
port link-type access
port default vlan 34

SW3

vlan batch 12 to 13 34

stp instance 12 root primary //设置为主根
stp instance 34 root secondary //设置为备根

stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface Vlanif12
ip address 192.168.12.3 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.12.254 //vrrp配置
vrrp vrid 1 priority 150

interface Vlanif13
ip address 10.0.13.3 255.255.255.0

interface Vlanif34
ip address 192.168.34.3 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.34.254

interface MEth0/0/1

interface GigabitEthernet0/0/1
port link-type access
port default vlan 13

interface GigabitEthernet0/0/2

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

ip route-static 0.0.0.0 0.0.0.0 10.0.13.1

SW4

vlan batch 12 14 34

stp instance 12 root secondary
stp instance 34 root primary

stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface Vlanif12
ip address 192.168.12.4 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.12.254

interface Vlanif14
ip address 10.0.14.4 255.255.255.0

interface Vlanif34
ip address 192.168.34.4 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.34.254
vrrp vrid 2 priority 150

interface MEth0/0/1

interface GigabitEthernet0/0/1

interface GigabitEthernet0/0/2
port link-type access
port default vlan 14

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

ip route-static 0.0.0.0 0.0.0.0 10.0.14.1

R1

interface GigabitEthernet0/0/0
ip address 10.0.12.1 255.255.255.0

interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0

interface GigabitEthernet0/0/2
ip address 10.0.14.1 255.255.255.0

interface LoopBack0
ip address 10.0.1.1 255.255.255.255

bgp 100
router-id 10.0.1.1
peer 10.0.2.2 as-number 100
peer 10.0.2.2 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
import-route static //导入静态,刚好静态通过ip route-static查看只有12、34段
peer 10.0.2.2 enable
peer 10.0.2.2 next-hop-local

ospf 1 router-id 10.0.1.1
area 0.0.0.0
network 10.0.1.1 0.0.0.0
network 10.0.12.1 0.0.0.0

ip route-static 192.168.12.0 255.255.255.0 10.0.13.3
ip route-static 192.168.12.0 255.255.255.0 10.0.14.4 preference 70
ip route-static 192.168.34.0 255.255.255.0 10.0.13.3 preference 70
ip route-static 192.168.34.0 255.255.255.0 10.0.14.4
//让12和34段的回去的包走原来出去的路径回包,源进源出

R2

isis 1
cost-style wide
network-entity 49.0001.0000.0000.0002.00
import-route ospf 1 level-1 //右边和r3建立的是级别1,这里导入ospf必须选择级别1

interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0

interface GigabitEthernet0/0/1
ip address 10.0.23.2 255.255.255.0
isis enable 1
isis circuit-level level-1 //只和右边r3建立的是级别1,所以不让这个口发级别2的包出

interface LoopBack0
ip address 10.0.2.2 255.255.255.255
isis enable 1

bgp 100
router-id 10.0.2.2
peer 10.0.1.1 as-number 100
peer 10.0.1.1 connect-interface LoopBack0
peer 10.0.3.3 as-number 100
peer 10.0.3.3 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
peer 10.0.1.1 enable
peer 10.0.1.1 reflect-client
peer 10.0.3.3 enable
peer 10.0.3.3 reflect-client

ospf 1 router-id 10.0.2.2
import-route isis 1
area 0.0.0.0
network 10.0.2.2 0.0.0.0
network 10.0.12.2 0.0.0.0

R3

dhcp enable

ip pool test
gateway-list 192.168.56.254
network 192.168.56.0 mask 255.255.255.0
excluded-ip-address 192.168.56.6
dns-list 192.168.1.1

isis 1
is-level level-1
cost-style wide
network-entity 49.0001.0000.0000.0003.00

firewall zone Local
priority 15

interface GigabitEthernet0/0/0

interface GigabitEthernet0/0/1
ip address 10.0.23.3 255.255.255.0
isis enable 1

interface GigabitEthernet0/0/2.35 //用子接口
dot1q termination vid 35
ip address 10.0.35.3 255.255.255.0
arp broadcast enable
dhcp select global

interface LoopBack0
ip address 10.0.3.3 255.255.255.255
isis enable 1

bgp 100
router-id 10.0.3.3
peer 10.0.2.2 as-number 100
peer 10.0.2.2 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
import-route static //导入静态,刚好静态通过ip route-static查看只有56段
peer 10.0.2.2 enable
peer 10.0.2.2 next-hop-local

ip route-static 192.168.56.0 255.255.255.0 10.0.35.5

SW5

vlan batch 35 56

dhcp enable

interface Vlanif35
ip address 10.0.35.5 255.255.255.0

interface Vlanif56
ip address 192.168.56.254 255.255.255.0
dhcp select relay //中继R3上面的dhcp地址池
dhcp relay server-ip 10.0.35.3

interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 35

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 56

ip route-static 0.0.0.0 0.0.0.0 10.0.35.3

SW6

vlan batch 56

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 56

interface GigabitEthernet0/0/10
port link-type access
port default vlan 56

interface GigabitEthernet0/0/11
port link-type access
port default vlan 56

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mfbz.cn/a/299430.html

如若内容造成侵权/违法违规/事实不符,请联系我们进行投诉反馈qq邮箱809451989@qq.com,一经查实,立即删除!

相关文章

基于 Python+Neo4j+医药数据,构建了一个知识图谱的自动问答系统

知识图谱是目前自然语言处理的一个热门方向。目前知识图谱在各个领域全面开花,如教育、医疗、司法、金融等。 本项目立足医药领域,以垂直型医药网站为数据来源,以疾病为核心,构建起一个包含7类规模为4.4万的知识实体,…

Apifox使用外部文件完成接口预处理

pm.executeAsync(filePath, args, options) filePath string 外部程序路径 args string[] 参数。调用 jar 包中的指定方法时,会使用 JSON.stringify 进行转换。除此之外非 >string 类型会进行隐式类型转换自动转换为 string 类型。 options Object command str…

数据结构期末模拟试卷

一、判断题 1.关键路径是AOE网中从源点到汇点的最短路径。(F) 在AOE网中,从源点到汇点最长的路径称为关键路径,在关键路径上的活动称为关键活动 2. 二叉排序树的查找效率和二叉排序树的髙度有关。(T) 最好…

【ARM 处理器】程序存储详解

本篇文章主要介绍ARM处理器,Code, RO-data,RW-data,ZI-data 知识以及程序存储情况 目录 1. 专业词汇2. 程序存储3. 程序空间计算 1. 专业词汇 Code : 代码区,存储在 ROM 区域RO-data:Read Only data,即只读数据域&…

TIA Portal 各版本安装指南

TIA Portal下载链接 https://pan.baidu.com/s/1Jat53vGz1rXfLm7kTldz-Q?pwd0531 1.鼠标右击【TIA portal V19 (64bit)】压缩包(先点击“显示更多选项”)选择【解压到 TIA portal V19 (64bit)】。 2.打开解压后的文件夹,鼠标右击【NoRestart…

windows 部署zlm

安装 双击下面的文件,进行安装 查看服务是否安装成功 在任务栏右键,选择任务管理器 选择服务,打开服务 显示正在运行 查看推流密钥

应用层

title: 应用层 date: 2023-12-20 21:03:48 tags: 知识总结 categories: 计算机网络 应用层:负责最直观的应用请求的封装、发起 一、域名系统DNS 连接在互联网上的主机不仅有IP地址,还有便于用户记忆的主机名字。域名系统DNS能够把互联网上的主机的名字…

软件测试作业‖若依系统的自动化+性能

以若依系统或者任意系统作为案例,题目:以某一 web系统为测试对象,完成以下文档的编写: (1)产品规格说明书(SPEC) 要求:功能完整(完成产品需求70%以上)、UI优良(每个页 面均有字段约束和合理的出错提示)、流程完整(一一对应功能)、流程合理(处理逻辑非…

C++笔记之cout高亮输出以及纯C++实现一个彩色时钟

C笔记之cout高亮输出以及纯C实现一个彩色时钟 code review! 文章目录 C\笔记之cout高亮输出以及纯C\实现一个彩色时钟一.cout高亮输出1.1.运行1.2.代码一1.3.代码二1.4.重置终端的文本格式到默认设置说明 二.纯C\实现一个彩色时钟2.1.运行2.2.main.cc2.3.cout带颜色打印输出技…

用通俗易懂的方式讲解:万字长文带你入门大模型

告别2023,迎接2024。大模型技术已成为业界关注焦点,你是否也渴望掌握这一领域却又不知从何学起? 本篇文章将特别针对入门新手,以浅显易懂的方式梳理大模型的发展历程、核心网络结构以及数据微调等关键技术。 如果你在阅读中收获…

常用Python自动化测试框架有哪些?

随着技术的进步和自动化技术的出现,市面上出现了一些自动化测试框架。只需要进行一些适用性和效率参数的调整,这些自动化测试框架就能够开箱即用,大大节省了测试时间。而且由于这些框架被广泛使用,他们具有很好的健壮性&#xff0…

纳尼??Rabbitmq居然被一个逗号给坑了??

转载说明:如果您喜欢这篇文章并打算转载它,请私信作者取得授权。感谢您喜爱本文,请文明转载,谢谢。 前言 这个问题发生在部署一套新的环境。搭建一个单节点的Rabbitmq,按照小伙伴写的部署文档搭建的。其中搭建步骤和我…

OpenMMlab导出CenterNet模型并用onnxruntime和tensorrt推理

导出onnx文件 直接使用脚本 import torch import torch.nn.functional as F from mmdet.apis import init_detectorconfig_file ./configs/centernet/centernet_r18_8xb16-crop512-140e_coco.py checkpoint_file ../checkpoints/centernet_resnet18_140e_coco_20210705_093…

Zoho SalesIQ:提高品牌在社交媒体上参与度的实用指南

在当今快节奏的数字世界中,品牌参与度变得比以往任何时候都更加重要。社交媒体在企业与客户互动方面发挥着至关重要的作用,了解如何很好地利用社交媒体来增强品牌参与度至关重要。 正如我们在之前的博客中所了解到的,品牌参与是指在品牌与其…

【计算机网络】网络基础--协议/网络协议/网络传输流程/地址管理

文章目录 一、计算机网络背景二、协议1.协议是什么2.为什么要有协议 三、网络协议1.为什么要进行协议分层2.OSI七层模型3.TCP/IP五层(或四层)模型 四、网络传输基本流程1.协议报头2.局域网3.数据包封装和分用4.网络传输流程图 五、网络中的地址管理1.认识IP地址2.认识MAC地址3.…

再次认识ultralytics项目(大目标检测、小目标检测、yolov8-ghost、旋转目标检测、自动标注)

Ultralytics YOLOv8 是一款前沿、最先进(SOTA)的模型,基于先前 YOLO 版本的成功,引入了新功能和改进,进一步提升性能和灵活性。YOLOv8 设计快速、准确且易于使用,使其成为各种物体检测与跟踪、实例分割、图…

GNSS观测值线性组合

1 在几何距离线性化中,不论变量x的估计值是多少,估值改正数的系数是不变的。 2.宽、窄巷组合(噪声放大倍数) 由于几何距离与频率无关,在宽巷组合中,可直接依据几何距离,四舍五入确定宽巷模糊度 …

SPR系列激光扫描红外单点测距传感器CANOPEN 软件调试方法

SPR系列激光扫描红外单点测距传感器可用于对物体进行非接触式距离测量,其应用场景十分广泛工业自动化:在生产 线、传送带等工业自动化场景中,可以使用红外测距传感器进行物体的距离测量和位置检测,以便机 器人或其他自动化设备准确…

百度自由DIY小程序源码:PHP+MySQL组合开发 带完整的搭建教程

随着移动互联网的快速发展,小程序已成为企业与用户互动的重要平台。然而,对于许多中小企业和开发者来说,从零开始开发一款小程序需要投入大量的时间和资源。 以下是部分代码示例: 系统特色功能一览: 1.高度自定义&…

图神经网络|8.2 图卷积的计算基本方法

不同于一般的神经网络,网络层数的并不用特别多。 原因是只需要少数次数迭代后(当迭代次数为图上的直径?任意两点最短距离的最大值?),某节点便可获取得到图上所有的节点。 通俗的理解是,在社会中…