CCNP课程实验-Route_Path_Control_CFG

目录

  • 实验条件
    • 网络拓朴
    • 需求
  • 配置实现
    • 基础配置
    • 需求实现
      • 1.A---F所有区用Loopback模拟,地址格式为:XX.XX.XX.XX/32,其中X为路由器编号。根据拓扑宣告进对应协议。A1和A2区为特例,A1:55.55.55.0/24,A2:55.55.66.0/24
      • 2.照拓扑图配置EIGRP/OSPF路由协议,关闭所有自动汇总。OSPF手动指明RID为Loopback 0地址。
      • 3.R4做双向重分布,R6把OSPF重分布到EIGRP,要求全网ping通。如无明确说明,禁止使用静态路由,禁止直接使用ACL过滤数据。
      • 4. A1区网段为55.55.55.0/24,配置R6使其禁止从R7学到此网段(要求:使用前缀列表)
      • 5. 在R4上配置,要求EIGRP重分布到OSPF时,B区Metric值为100,类型为E1;C区Metric值为200,类型为E1。 其他路由按照默认设置。
      • 6. 在R1的Area 0中增加以下网段:11.11.1.0/24、11.11.2.0/24 (用Loopback模拟),要求在R2上配置最精确的路由汇总,并且只允许在III区学到该汇总路由。
      • 7. 要求A1到F区的数据流走R4,A2到E区的数据流走R6(R5带A1和A2的源地址采用Traceroute测试)
      • 8. 在R7上配置,使其路由表中显示去往E、F区的下一跳是R6。
      • 10. 在R4上配置,使其访问E区走 I 区 --> III 区,其他路线不变 (要求:不允许策略路由和分发列表)

实验条件

网络拓朴

在这里插入图片描述
拓扑中的IP地址段采用:172.8.AB.X/24,其中AB为两台路由器编号组合,
例如:R3-R6之间的AB为36,X为路由器编号,例如R3的X=3
所有路由器都有一个Loopback 0接口,地址格式为:X.X.X.X/32,其中X为路由器编号。
没有特殊要求,不允许使用静态路由。

需求

  1. A—F所有区用Loopback模拟,地址格式为:XX.XX.XX.XX/32,其中X为路由器编号。根据拓扑宣告进对应协议。A1和A2区为特例,A1:55.55.55.0/24,A2:55.55.66.0/24。
  2. 照拓扑图配置EIGRP/OSPF路由协议,关闭所有自动汇总。OSPF手动指明RID为Loopback 0地址。
  3. R4做双向重分布,R6把OSPF重分布到EIGRP,要求全网ping通。如无明确说明,禁止使用静态路由,禁止直接使用ACL过滤数据。
  4. A1区网段为55.55.55.0/24,配置R6使其禁止从R7学到此网段(要求:使用前缀列表)
  5. 在R4上配置,要求EIGRP重分布到OSPF时,B区Metric值为100,类型为E1;C区Metric值为200,类型为E1。 其他路由按照默认设置。
  6. 在R1的Area 0中增加以下网段:11.11.1.0/24、11.11.2.0/24 (用Loopback模拟),要求在R2上配置最精确的路由汇总,并且只允许在III区学到该汇总路由。
  7. 要求A1到F区的数据流走R4,A2到E区的数据流走R6(R5带A1和A2的源地址采用Traceroute测试)
  8. 在R7上配置,使其路由表中显示去往E、F区的下一跳是R6。
  9. 在R4上配置,使其访问E区走 I 区 --> III 区,其他路线不变 (要求:不允许策略路由和分发列表)

配置实现

基础配置

R1

R1#show run | s interface
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 89 area 2
interface Ethernet0/0
 ip address 14.1.1.1 255.255.255.0
 ip ospf 89 area 2
 duplex auto
interface Ethernet0/1
 ip address 12.1.1.1 255.255.255.0
 ip ospf 89 area 0
 duplex auto
R1#show run | s rout 
router ospf 89
 router-id 1.1.1.1

R2

R2#show run | s interface 
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip ospf 89 area 0
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
interface Ethernet0/0
 ip address 23.1.1.2 255.255.255.0
 ip ospf 89 area 3
 duplex auto
interface Ethernet0/1
 ip address 12.1.1.2 255.255.255.0
 ip ospf 89 area 0
 duplex auto
R2#show run | s route
router ospf 89
 router-id 2.2.2.2

R3

R3(config-if)#do show run | s interface
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 89 area 3
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
interface Ethernet0/0
 ip address 23.1.1.3 255.255.255.0
 ip ospf 89 area 3
 duplex auto
interface Ethernet0/1
 ip address 36.1.1.3 255.255.255.0
 ip ospf 89 area 3
 duplex auto
R3(config-if)#do show run | s route
router ospf 89
 router-id 3.3.3.3

R4

R4(config-route-map)#do show run | s interface  
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip ospf 89 area 2
interface Loopback1
 ip address 44.44.44.44 255.255.255.255
interface Ethernet0/0
 ip address 14.1.1.4 255.255.255.0
 ip ospf 89 area 2
 duplex auto
interface Ethernet0/1
 ip address 47.1.1.4 255.255.255.0
 duplex auto
R4(config-route-map)#do show run | s route
router eigrp 1
 network 44.44.44.44 0.0.0.0
 network 47.1.1.4 0.0.0.0
 eigrp router-id 4.4.4.4
router ospf 89
 router-id 4.4.4.4

R5

R5(config-router)#do show run | s interface 
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
interface Loopback1
 ip address 55.55.55.55 255.255.255.0
interface Loopback2
 ip address 55.55.66.66 255.255.255.0
interface Ethernet0/2
 ip address 57.1.1.5 255.255.255.0
 duplex auto
R5(config-router)#do show run | s route
router eigrp 1
 network 0.0.0.0
 eigrp router-id 5.5.5.5
R5(config-router)#

R6

R6(config-router)#do show run | s interface 
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip ospf 89 area 3
interface Loopback1
 ip address 66.66.66.66 255.255.255.255
interface Ethernet0/0
 ip address 67.1.1.6 255.255.255.0
 duplex auto
interface Ethernet0/1
 ip address 36.1.1.6 255.255.255.0
 ip ospf 89 area 3
 duplex auto
R6(config-router)#do show run | s route
router eigrp 1
 distribute-list prefix A1 in 
 network 66.66.66.66 0.0.0.0
 network 67.1.1.6 0.0.0.0
 eigrp router-id 6.6.6.6
router ospf 89
 router-id 6.6.6.6
R6(config-router)#

R7

R7(config-router)#do show run | s route
router eigrp 1
 network 0.0.0.0
 eigrp router-id 7.7.7.7
R7(config-router)#do show run | s interface 
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
interface Loopback1
 ip address 77.77.77.77 255.255.255.255
interface Ethernet0/0
 ip address 67.1.1.7 255.255.255.0
 duplex auto
interface Ethernet0/1
 ip address 47.1.1.7 255.255.255.0
 duplex auto
interface Ethernet0/2
 ip address 57.1.1.7 255.255.255.0
 duplex auto
R7(config-router)#do show run | s route
router eigrp 1
 network 0.0.0.0
 eigrp router-id 7.7.7.7
R7(config-router)#

需求实现

1.A—F所有区用Loopback模拟,地址格式为:XX.XX.XX.XX/32,其中X为路由器编号。根据拓扑宣告进对应协议。A1和A2区为特例,A1:55.55.55.0/24,A2:55.55.66.0/24

基础配置中已完成

2.照拓扑图配置EIGRP/OSPF路由协议,关闭所有自动汇总。OSPF手动指明RID为Loopback 0地址。

基础配置中已完成

3.R4做双向重分布,R6把OSPF重分布到EIGRP,要求全网ping通。如无明确说明,禁止使用静态路由,禁止直接使用ACL过滤数据。

R4:

router eigrp 1
redistribute ospf 89 metric 10000 100 255 1 1500


router ospf 89
redistribute eigrp 1 subnets

R6:

router eigrp 1
redistribute ospf 89 metric 10000 100 255 1 1500

4. A1区网段为55.55.55.0/24,配置R6使其禁止从R7学到此网段(要求:使用前缀列表)

R6:

ip prefix-list A1 deny 55.55.55.0/24
ip prefix-list A1 permit 0.0.0.0/0 le 32
router eigrp 1
distribute-list prefix A1 in Ethernet0/0

5. 在R4上配置,要求EIGRP重分布到OSPF时,B区Metric值为100,类型为E1;C区Metric值为200,类型为E1。 其他路由按照默认设置。

R4:

access-list 1 permit 44.44.44.44
access-list 2 permit 66.66.66.66

route-map BCarea permit 10
 match ip address 1
 set metric 100
 set metric-type type-1
route-map BCarea permit 20
 match ip address 2
 set metric 200
 set metric-type type-1
route-map BCarea permit 30

router ospf 89
redistribute eigrp 1 subnets route-map BCarea

6. 在R1的Area 0中增加以下网段:11.11.1.0/24、11.11.2.0/24 (用Loopback模拟),要求在R2上配置最精确的路由汇总,并且只允许在III区学到该汇总路由。

R1:

interface Loopback1
 ip address 11.11.1.1 255.255.255.0
interface Loopback2
 ip address 11.11.2.1 255.255.255.0
router ospf 89
 network 11.11.1.1 0.0.0.0 area 0
 network 11.11.2.1 0.0.0.0 area 0

R2:

router ospf 89
 area 0 range 11.11.0.0 255.255.252.0

现在要将这个汇总的路由限制在III区内,那就是要在R6上重分布到I区时,拦截该条汇总路由,不让他分布进I区的eigrp协议中
R6:

ip prefix-list R1-summary permit 11.11.0.0/22	// 精确匹配这条路由

route-map R1-summary deny 10		//拒绝match的路由
 match ip address prefix-list R1-summary
route-map R1-summary permit 20

router eigrp 1
 redistribute ospf 89 metric 10000 100 255 1 1500 route-map R1-summary

7. 要求A1到F区的数据流走R4,A2到E区的数据流走R6(R5带A1和A2的源地址采用Traceroute测试)

这个需求可以使用策略路由来实现这个功能, 根据源地址来决定路由走向,先定义两个ACL
R7:

access-list 155 permit 55.55.55.0 0.0.0.255 host 22.22.22.22 // 扩展ACL
access-list 166 permit 55.55.66.0 0.0.0.255 host 33.33.33.33

route-map PBR permit 10
 match ip address 155
 set ip next-hop 47.1.1.4
route-map PBR permit 20
 match ip address 166
 set ip next-hop 67.1.1.6A1A2区进入R7的时候,配置策略路由
interface ethernet 0/2
 ip policy route-map PBR

测试结果
R5:

R5#traceroute 22.22.22.22 source 55.55.55.55
Type escape sequence to abort.
Tracing the route to 22.22.22.22
VRF info: (vrf in name/id, vrf out name/id)
  1 57.1.1.7 0 msec 1 msec 0 msec
  2 47.1.1.4 0 msec 1 msec 0 msec
  3 14.1.1.1 1 msec 0 msec 1 msec
  4 12.1.1.2 0 msec *  1 msec
R5#traceroute 33.33.33.33 source 55.55.66.66
Type escape sequence to abort.
Tracing the route to 33.33.33.33
VRF info: (vrf in name/id, vrf out name/id)
  1 57.1.1.7 0 msec 1 msec 0 msec
  2 67.1.1.6 1 msec 0 msec 0 msec
  3 36.1.1.3 1 msec *  0 msec

8. 在R7上配置,使其路由表中显示去往E、F区的下一跳是R6。

去往E、F区的路由是 22.22.22.22 33.33.33.33
R7: 路由表

      22.0.0.0/32 is subnetted, 1 subnets
D EX     22.22.22.22 [170/307200] via 67.1.1.6, 04:00:32, Ethernet0/0
                     [170/307200] via 47.1.1.4, 04:00:32, Ethernet0/1
      33.0.0.0/32 is subnetted, 1 subnets
D EX     33.33.33.33 [170/307200] via 67.1.1.6, 03:46:12, Ethernet0/0
                     [170/307200] via 47.1.1.4, 03:46:12, Ethernet0/1

从路由表上得到的信息是,等价负载均衡的,现在只需增大去往R4的metric值,使的R6的metric优先,就可以达到目的
R7:

access-list 10 permit 22.22.22.22
access-list 10 permit 33.33.33.33
router eigrp 1
 offset-list 10 in 1 ethernet 0/1	//从R4通告过来的,通过ethernet 0/1接口 进来的方向

路由表结果

      22.0.0.0/32 is subnetted, 1 subnets
D EX     22.22.22.22 [170/307200] via 67.1.1.6, 00:00:02, Ethernet0/0
      23.0.0.0/24 is subnetted, 1 subnets
D EX     23.1.1.0 [170/307200] via 67.1.1.6, 00:00:02, Ethernet0/0
                  [170/307200] via 47.1.1.4, 00:00:02, Ethernet0/1
      33.0.0.0/32 is subnetted, 1 subnets
D EX     33.33.33.33 [170/307200] via 67.1.1.6, 00:00:02, Ethernet0/0
R7(config-router)#do show ip eigrp topology 22.22.22.22/32
EIGRP-IPv4 Topology Entry for AS(1)/ID(7.7.7.7) for 22.22.22.22/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 307200
  Descriptor Blocks:
  67.1.1.6 (Ethernet0/0), from 67.1.1.6, Send flag is 0x0
      Composite metric is (307200/281600), route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 255/255
        Minimum MTU is 1500
        Hop count is 1
        Originating router is 6.6.6.6
      External data:
        AS number of route is 89
        External protocol is OSPF, external metric is 21
        Administrator tag is 0 (0x00000000)
  47.1.1.4 (Ethernet0/1), from 47.1.1.4, Send flag is 0x0
      Composite metric is (307201/281600), route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 255/255
        Minimum MTU is 1500
        Hop count is 1
        Originating router is 4.4.4.4
      External data:
        AS number of route is 89
        External protocol is OSPF, external metric is 21
        Administrator tag is 0 (0x00000000)
  67.1.1.6 (Ethernet0/0), from 67.1.1.6, Send flag is 0x0
      Composite metric is (307200/281600), route is External
  47.1.1.4 (Ethernet0/1), from 47.1.1.4, Send flag is 0x0
      Composite metric is (307201/281600), route is External

R4上的路由metric FD值为307201,比R6上的307200大了1

10. 在R4上配置,使其访问E区走 I 区 --> III 区,其他路线不变 (要求:不允许策略路由和分发列表)

R4上查询路由表得到

      33.0.0.0/32 is subnetted, 1 subnets
O IA     33.33.33.33 [110/31] via 14.1.1.1, 00:20:20, Ethernet0/0

查询Eigrp拓扑表可以查到以下记录

R4#show ip eigrp topology 33.33.33.33/32                 
EIGRP-IPv4 Topology Entry for AS(1)/ID(4.4.4.4) for 33.33.33.33/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Descriptor Blocks:
  14.1.1.1, from Redistributed, Send flag is 0x0
      Composite metric is (281600/0), route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 255/255
        Minimum MTU is 1500
        Hop count is 0
        Originating router is 4.4.4.4
      External data:
        AS number of route is 89
        External protocol is OSPF, external metric is 31
        Administrator tag is 0 (0x00000000)
  47.1.1.7 (Ethernet0/1), from 47.1.1.7, Send flag is 0x0
      Composite metric is (332800/307200), route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 3000 microseconds
        Reliability is 255/255
        Load is 255/255
        Minimum MTU is 1500
        Hop count is 2
        Originating router is 6.6.6.6
      External data:
        AS number of route is 89
        External protocol is OSPF, external metric is 11
        Administrator tag is 0 (0x00000000)

我的想法是通过在eigrp里修改distance,达到目的,具体是这样的

access-list 33 permit 33.33.33.33 

router eigrp 1
 distance 109 47.1.1.7 0.0.0.0 33

但是可惜没有能达到目的,因为33.33.33.33是eigrp外部路由,不能生效。 所以就改将ospf OIA的AD值为110的那条记录。修改成171,因为eigrp外部路由的AD值为170,这样的话,ospf的那条路由记录就会竞争RIB失效。从而达到我们的目的,从I区,III区走。

access-list 33 permit 33.33.33.33 

router ospf 89
 distance 171 0.0.0.0 255.255.255.255 33

查询路由表得到

      33.0.0.0/32 is subnetted, 1 subnets
D EX     33.33.33.33 [170/332800] via 47.1.1.7, 00:00:07, Ethernet0/1

测试路径
R4#traceroute 33.33.33.33
Type escape sequence to abort.
Tracing the route to 33.33.33.33
VRF info: (vrf in name/id, vrf out name/id)
  1 47.1.1.7 0 msec 0 msec 0 msec
  2 67.1.1.6 1 msec 0 msec 0 msec
  3 36.1.1.3 0 msec *  1 msec
R4#

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mfbz.cn/a/280941.html

如若内容造成侵权/违法违规/事实不符,请联系我们进行投诉反馈qq邮箱809451989@qq.com,一经查实,立即删除!

相关文章

【Vue2+3入门到实战】(16)VUEVue路由的重定向、404、编程式导航、path路径跳转传参 详细代码示例

目录 一、Vue路由-重定向1.问题2.解决方案3.语法4.代码演示 二、Vue路由-4041.作用2.位置3.语法4.代码示例 三、Vue路由-模式设置1.问题2.语法 四、编程式导航-两种路由跳转方式1.问题2.方案3.语法4.path路径跳转语法5.代码演示 path跳转方式6.name命名路由跳转7.代码演示通过n…

C++day4作业

定义一个Person类,私有成员int age,string &name,定义一个Stu类,包含私有成员double *score,写出两个类的构造函数、析构函数、拷贝构造和拷贝赋值函数,完成对Person的运算符重载(算术运算符、条件运算…

利用idea+ jclasslib插件查看和分析 Java 类文件的字节码

jclasslib介绍 jclasslib 插件是一个用于 IntelliJ IDEA 的工具,它允许开发者在集成开发环境(IDE)内直接查看和分析 Java 类文件的字节码。这个插件尤其对于想要深入了解 Java 字节码、类加载机制、以及 Java 虚拟机(JVM&#xf…

第4课 FFmpeg读取本地mp4文件并显示

在上节课,我们使用FFmpeg实现了一个最简单的rtmp播放器,它看起来工作正常。这节课,我们尝试让它来播放本地的mp4文件试试。 1.将原rtmp地址修改为本地mp4地址: const char *inFileName "d:\\mp4\\dtz.mp4"; 调试运…

阿里后端实习二面

阿里后端实习二面 记录面试题目,希望可以帮助到大家 类加载的流程? 类加载分为三个部分:加载、连接、初始化 加载 类的加载主要的职责为将.class文件的二进制字节流读入内存(JDK1.7及之前为JVM内存,JDK1.8及之后为本地内存)&…

GO学习记录 —— 创建一个GO项目

文章目录 前言一、项目介绍二、目录介绍三、创建过程1.引入Gin框架、创建main2.加载配置文件3.连接MySQL、redis4.创建结构体5.错误处理、返回响应处理 前言 代码地址 下载地址:https://github.com/Lee-ZiMu/Golang-Init.git 一、项目介绍 1、使用Gin框架来创建项…

[Angular] 笔记 21:@ViewChild

chatgpt: 在 Angular 中,ViewChild 是一个装饰器,用于在组件类中获取对模板中子元素、指令或组件的引用。它允许你在组件类中访问模板中的特定元素,以便可以直接操作或与其交互。 例如,如果你在模板中有一个子组件或一个具有本地…

【shell】命令行自动补全(compgen、complete、compopt)

目录 用途 小例子 说明 进阶-多级补齐 Bash自动补齐原理 用途 自编写的Shell脚本/命令,很多时候都需要输入一定的参数。当参数较多而且较复制的时候,如果能使用Tab键补全就显得非常的便利。 小例子 例如,我们自定义一个命令 footest function…

使用flutter开发windows桌面软件读取ACR22U设备的nfc卡片id,5分钟搞定demo

最近有个需求,要使用acr122u读卡器插入电脑usb口,然后读取nfc卡片的id,并和用户账号绑定,调研了很多方式,之前使用rust实现过一次,还有go实现过一次,然后使用electron的时候遇到安装pcsc-lite失…

ORACLE P6 v23.12 最新虚拟机(VM)全套系统环境分享

引言 根据上周的计划,我简单制作了两套基于ORACLE Primavera P6 最新发布的23.12版本预构建了虚拟机环境,里面包含了全套P6 最新版应用服务 此虚拟机仅用于演示、培训和测试目的。如您在生产环境中使用此虚拟机,请先与Oracle Primavera销售代…

python常见报错信息!错误和异常!附带处理方法

作为 Python 初学者,在刚学习 Python 编程时,经常会看到一些报错信息。 Python 有两种错误很容易辨认:语法错误和异常。 Python assert(断言)用于判断一个表达式,在表达式条件为 false 的时候触发异常。 …

【UE5蓝图】读取本地json文件修改窗口大小

效果 插件 蓝图 1.判断文件存在 2.1文件不存在,生成文件 {"ResolutionX":540, "ResolutionY":960} 2.2文件存在,直接读取 3.设置窗口大小 遇到的坑 1.分辨率太大,导致效果不理想,建议先往小填写。 2.选对…

QT 利用开源7z 实现解压各种压缩包,包括进度条和文件名的显示(zip,7z,rar,iso等50多种格式)

想做一个winRAR一样的解压软件吗?很简单,利用开源的7z库就能实现。我看网上其他人说的方法不敢苟同,误人子弟。以前自己在项目中使用过7z,这次又有需要,就想记录下来。如果你研究过如何用7z的话,一定知道7z的每一个GUID都代表了一种格式,50多种GUID也就有50多个格式,最…

Unity坦克大战开发全流程——开始场景——音效数据逻辑

开始场景——音效数据逻辑 从这里开始到后面的三小节我们都将干一件很重要的事——数据存储,只有实现了数据存储才能在再次进入游戏时保持游戏数据不被丢失。 类图分析:数据管理类是一个大类,它其中关联了两个类(这两个类都是数据…

迭代归并:归并排序非递归实现解析

🎬 鸽芷咕:个人主页 🔥 个人专栏: 《数据结构&算法》《粉丝福利》 ⛺️生活的理想,就是为了理想的生活! 📋 前言 归并排序的思想上我们已经全部介绍完了,但是同时也面临和快速排序一样的问题那就是递…

Go语言中的性能考虑和优化

优化您的Go代码以达到最佳性能 性能优化是软件开发的关键方面,无论您使用哪种编程语言。在这篇文章中,我们将探讨Go语言中的性能考虑和优化,Go是一种以其效率而著称的静态类型和编译语言。我们将深入探讨三个关键领域:分析并发代…

用CSS中的动画效果做一个转动的表

<!DOCTYPE html> <html lang"en"><head><meta charset"utf-8"><title></title><style>*{margin:0;padding:0;} /*制作表的样式*/.clock{width: 500px;height: 500px;margin:0 auto;margin-top:100px;border-rad…

【Electron】webview 实现网页内嵌

实现效果&#xff1a; 当在输入框内输入某个网址后并点击button按钮 , 该网址内容就展示到下面 踩到的坑&#xff1a;之前通过web技术实现 iframe 标签内嵌会出现 同源策略&#xff0c;同时尝试过 vue.config.ts 内配置跨域项 那样确实 是实现啦 但不知道如何动态切换 tagert …

深入浅出Java虚拟机

文章目录 总体图类装载子系统一、类的加载过程一、加载二、链接三、初始化 二、类的加载器 运行时数据区一、程序计数器(ProgramCounter)二、虚拟机栈( Java Stack )三、本地方法栈&#xff08; Native Method Stack &#xff09;四、堆内存&#xff08;Direct Memory&#xff…

51单片机的中断相关知识

51单片机的中断相关知识点 一、中断概念和功能 概念 程序执行过程中CPU会遇到一些特殊情况&#xff0c;是正在执行的程序被“中断”&#xff0c;cpu中止原来正在执行的程序&#xff0c;转到处理异常情况或特殊事件的程序去执行&#xff0c;结束后再返回到原被中止的程序处(断…