首页 > 编程学习 > CentOS7 控制台上安装运行 vmware workstation 备忘录

目标平台 CentOS 7.5.1804 无桌面,要跑个 Ubuntu.vmx

1.安装依赖库

yum -y install perl gcc kernel-devel libX11 libXinerama libXcursor libXtst

注意通过 uname -r 查询内核版本(如我的服务器为 3.10.0-862.el7.x86_64),然后到 CentOS 官网的历史版本里找到对应的 rpm 包 (kernel-devel-3.10.0-862.el7.x86_64.rpm) 手动安装。

如果通过 yum 好像只能安装最新的 1160 版本,头文件版本不匹配会导致后面 vmware 安装时编译失败!

2.下载安装包

在 vmware 官网下载 VMware-Workstation-Full-{版本号}.x86_64.bundle 安装包(或者网上一搜也有),我前前后后下载了好几个 bundle 包(后面会说为啥)

VMware-Workstation-Full-12.1.1-3770994.x86_64.bundle
VMware-Workstation-Full-14.1.3-9474260.x86_64.bundle
VMware-Workstation-Full-15.1.0-13591040.x86_64.bundle

3.在控制台下安装

chmod +x *.bundle

./VMware-Workstation-Full-{版本号}.x86_64.bundle --console --eulas-agreed --required -s vmware-workstation serialNumber {激活序列号}

激活序列号欠奉(自己搜吧)

安装完成后,运行 ps -aux|grep vmware 查看进程或者 vmware-modconfig --install-status 查看安装状态,

#  vmware-modconfig --install-status
[AppLoader] GLib does not have GSettings support.
vmmon: installed
vmnet: installed
vmci: other
vsock: other

一般而言只要 vmmon、vmnet 是 installed, vmware 就能干活了

4.问题及解决

4.1 安装和运行

最开始安装 v12 的版本,检查结果是 vmmon、vmnet 工作不正常,据说是 v12 版本存在问题,建议升级到 v14。
卸载 v12,安装 v14 的版本成功,但是 vmrun start Ubuntu.vmx nogui 报错 "Error: The operation was canceled",怀疑这个 vmx 是通过比 v14 更高版本创建的,于是换 v15 试试。
卸载 v14 (建议保留 vmware 配置,我开始没保留配置,结果 v15 安装后,网卡始终是"正在加载虚拟网络"的状态不可用,于是又机智地卸载了 v15 重装 v14,再次卸载并保留 v14 的配置),安装 v15,vmrun start Ubuntu.vmx nogui 成功

以上就是我下载了三个版本的  bundle 包的渊源……

4.2 没有GUI

因为不知道 Ubuntu 的 IP 地址,命令行下直接启动 vmx 后找不到服务器,无法远程登录。
解决的方法

1) 先停止 Ubuntu.vmx,
2) 在 /var/lib/vmware/Shared VMs/ 下,将目录 Ubuntu 改名 Ubuntu1
3) 在 Window 桌面的 vmware workstation 上连接到 CentOS,并创建一个名为 Ubuntu 的虚拟机,无需运行
4) 回到 CentOS 上,删除 /var/lib/vmware/Shared VMs/ 下新建的 Ubuntu 目录,将 Ubuntu1 改回 Ubuntu

这样就可以在桌面的 vmware workstation 上远程启动并操作 Ubuntu 了

 

Copyright © 2010-2022 mfbz.cn 版权所有 |关于我们| 联系方式|豫ICP备15888888号